Server Errors on Shields component
Incident Report for Terms of Service; Didn't Read
Postmortem

After the Maintenance on Apr 29 we have upgraded our PHP Version from 7.4 to 8.0. This major change introduced two bugs in our Shields Systems where an invalid class has been called and a count comparison against a boolean has been made. This bug has not been noticed in earlier versions of PHP as PHP8 introduced a stricter type matching.

The Fix can be found in this commit: https://github.com/tosdr/CrispCMS/commit/57dbdee4d2d55de373bd36ec3ed43e06fff16641

Posted Apr 30, 2021 - 11:27 CEST

Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 11:21 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2021 - 11:16 CEST
Identified
The issue lies in the POSER library our Shields API uses. We are deploying a fix.
Posted Apr 30, 2021 - 11:04 CEST
Investigating
We are currently investigating a server error on the Shields API.
Posted Apr 30, 2021 - 10:54 CEST
This incident affected: Infrastructure (Shields API).